System Requirements

Incident Management runs on the latest versions the following Internet browsers:

  • Google Chrome (latest version)
  • Microsoft Edge (latest version)
  • Internet Explorer 11

Visit the links below to download Chrome, Edge, or Internet Explorer 11 and ensure your computer meets the minimum system requirements.